MAKEMSI quickly and reliably creates MSI files in a non-programmatic way
Have your say! Join the MAKEMSI discussion list or view archive! Suggest improvements. No question too simple or too complex.
[Bottom][Contents][Prev]: Prevent Downgrades of Your Product[Next]: Z: Available?
Have your say! Join the MAKEMSI discussion list or view archive! Suggest improvements. No question too simple or too complex.
\->Tips and Tricks->Launch Conditions->Windows 2000 or Greater?

Launch Condition: Windows 2000 or Greater?

We only want to install this product on Windows 2000, XP or above:

<$AbortIf Condition=^not VersionNT OR (VersionNT < 500)^ Message=^Can only be installed on Windows 2000, XP or greater.^>

The condition "not VersionNT" is checking to see if the "VersionNT" property exists (it won't for WIN95, WIN98 and WINME) and "VersionNT < 500" is checking if the NT version is less than "5.00" (correct value for WIN2000).

See the online documentation for a list of operating system related property values.


Microsoft awarded me an MVP (Most Valuable Professional award) in 2004, 2005, 2006, 2007, 2008 & 2009 for the Windows SDK (Windows Installer) area.Please email me any feedback, additional information or corrections.
See this page online (look for updates)

[Top][Contents][Prev]: Prevent Downgrades of Your Product[Next]: Z: Available?


MAKEMSI© is (C)opyright Dennis Bareis 2003-2008 (All rights reserved).
Saturday December 09 2017 at 9:30am
Visit MAKEMSI's Home Page
Microsoft awarded me an MVP (Most Valuable Professional award) in 2004, 2005, 2006, 2007, 2008 & 2009 for the Windows SDK (Windows Installer) area.